Print Top-ups & Job Ticketing

Incident Report for University for the Creative Arts

Update

We are awaiting further instruction from our third parties to restore service as quickly as possible.
Posted Aug 28, 2026 - 17:11 BST

Update

We are continuing to work with our third parties. Further brief outages to printing may be experienced during this time.
Posted Aug 28, 2026 - 13:05 BST

Update

Printing is available again. We are working on the final parts to restore the print top-ups and job ticketing.
Posted Aug 28, 2026 - 10:17 BST

Identified

An issue has been identified. Printing services will be briefly unavailable whilst we apply a fix.
Further updates will be posted when services have been restored.
Posted Aug 28, 2026 - 10:04 BST

Investigating

We are aware students are currently unable to top-up print credits. In addition, access to Job Ticketing (Print Bureau's) is also unavailable.

We are working with our vendor to resolve this issue.

We anticipate a short outage of printing will be required later this morning, and will communicate details accordingly.
Posted Aug 28, 2026 - 09:22 BST
This incident affects: Digital Services (Printing Services).